Evap system problem

Results 1 to 8 of 8

Thread: Evap system problem

  1. #1
    Junior Member Gentryd's Avatar
    Join Date
    Jul 2019
    Posts
    4

    Evap system problem

    Okay so I have a 2013 Scion FR-S which is turbo charged that I recently bought. The check engine light has been on as well as the traction control. I have evap leak codes big and small but I can not find any leaks anywhere. I’m curious before I go looking to drop my diff to get to my canister, would it be something to do with the unplugging of the purge valve for the boost control valve. I really have know idea about these things and Im having a hard time finding articles about boosted frs 😂
    Quick reply to this message Reply  

  2. Remove Advertisements
    FR-SForum.com
    Advertisements
     

  3. #2
    ADMINISTRATORcolor> TrailDust's Avatar
    Join Date
    Oct 2010
    Location
    Kalifornistan
    Posts
    984
    Which codes have you gotten so far?
    Quick reply to this message Reply  

  4. #3
    Junior Member Gentryd's Avatar
    Join Date
    Jul 2019
    Posts
    4
    P0455 for large leak and P0456 for small leak. Which makes me believe it’s the vent valve close to the charcoal canister not closing. I assume from winter time due to freezing temps and it somehow breaking or even water getting in which is a good possibility if this car was ran through snow. I’m probably just gunna drop the back and replace the entire canister and everything after I get back from Florida. Let me know what you think
    Quick reply to this message Reply  

  5. Remove Advertisements
    FR-SForum.com
    Advertisements
     

  6. #4
    ADMINISTRATORcolor> TrailDust's Avatar
    Join Date
    Oct 2010
    Location
    Kalifornistan
    Posts
    984
    I agree. If it had been the 456 code only, then I'd have suspected a gas cap issue, but that code plus the 455 and I think the charcoal canister the likely culprit. Let us know how it turns out, but I think you've got the correct solution.
    Quick reply to this message Reply  

  7. #5
    Junior Member Gentryd's Avatar
    Join Date
    Jul 2019
    Posts
    4
    Okay I will! Thanks!
    Quick reply to this message Reply  

  8. #6
    ADMINISTRATORcolor> TrailDust's Avatar
    Join Date
    Oct 2010
    Location
    Kalifornistan
    Posts
    984
    Did you ever find a resolution?
    Quick reply to this message Reply  

  9. #7
    Junior Member Gentryd's Avatar
    Join Date
    Jul 2019
    Posts
    4
    Quote Originally Posted by TrailDust View Post
    Did you ever find a resolution?
    So I found out that it’s not the evap causing my rough idle and hesitation. And the code being thrown. It was actually my injectors putting to much fuel out into my car
    Quick reply to this message Reply  

  10. #8
    ADMINISTRATORcolor> TrailDust's Avatar
    Join Date
    Oct 2010
    Location
    Kalifornistan
    Posts
    984

    Thumbs up

    Interesting. Thank you for the update!
    Quick reply to this message Reply  

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0